Posts Tagged 'Reporting Services'

The request failed with HTTP status 401: Unauthorized in Report Services 2008 Sharepoint Integration

Today I tried to integrate Reporting Services and Sharepoint. The setup consisted of three servers:

  • SQL 2008
  • Reporting Services 2008
  • Sharepoint (WSS 3.0) with Reporting Services Addins

When I tried to connect Sharepoint to the Reporting Services Webservice using the Central Administration, I got the following error:

The request failed with HTTP status 401: Unauthorized

However when I manually visited the webservice through the browser @ http://myserver/ReportServer, everything worked fine. So why did the authentication fail for Sharepoint?

My Sharepoint setup uses NTLM authentication only, therefore Reporting Services must be configured for the same authentication type as well. After reading through tons of KB articles and posts, i finally found a solution to the problem:

  1. On the Reporting Services Server, open the config file rsreportserver.config (you find it in the Reporting Services folder)
  2. Look for the Autentication configuration node
  3. Remove the RSWindowsNegotiate setting

The config section in question should now look like this:

<Authentication>
  <AuthenticationTypes>
    <!-- <RSWindowsNegotiate/> -->
    <RSWindowsNTLM/>
  </AuthenticationTypes>
  <EnableAuthPersistence>true</EnableAuthPersistence>
</Autentication>

That way, only NTLM is used for authentication. This fixed it for me 🙂

Advertisements